Installing Microsoft LocStudio 4.8 on Windows 7

I have experienced problems installing LocStudio 4.8 on Windows 7.

When installing I get an error that .NET Framework 2.0 must be installed, but when installing .NET Framework 2.0 I get an error that this is already part of the operating system.

I found out that the problem is related to .NET Framework 4.

To solve the problem I uninstalled .NET Framework 4.0 Client Profile. After this I could install LocStudio 4.8.

This does not solve the problem completely though.

After installing LocStudio 4.8 it still didn’t run, and I got the error ‘Localization Studio Entry Program stopped working’.

The problem can be solved by installing the .NET Framework 4.0 Standalone Installer (http://www.microsoft.com/downloads/details.aspx?FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7&displaylang=en) instead of installing .NET Framework 4.0 using Microsoft Web Installer (or do not install .NET Framework 4.0 unless it is required for other software).

Update (Nov. 23, 2010):

This is the process to follow if you install LocStudio 4.8 on Windows 7 and get the error that .NET Framework 2 is required:

  1. Ignore and forget the error.
  2. Uninstall .NET Framework 4.0 if it is already installed.
  3. Install .NET Framework 4.0 Standalone Installer (http://www.microsoft.com/downloads/details.aspx?FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7&displaylang=en).
  4. Uninstall .NET Framework 4.0 Client Profile.
  5. Install LocStudio 4.8.
9 Comments
  1. Hi Johnny,

    I just installed NET Framework 4.0 Standalone Installer and then tried to install LocStudio 4.8, but it didn`t work. Perhaps I did not understand exactly what you did… Did you first install NET Framework 2.0, then LocStudio 4.8 and then NET Framework 4.0 Standalone Installer? Any help would be most welcome!

    Regards,
    Isabelle

    • Hi Isabelle,

      You did it correctly, but before installing LocStudio you must uninstall ‘.NET Framework 4.0 Client Profile’ through Windows Control Panel > Add/Remove Programs.

      That worked for me. Let me know if that helps.

  2. Hmm, I have just
    1. uninstalled 4.0 Client Profile,
    2. installed LocStudio 4.8,
    (didn’t install Framework 4.0 Standalone Installer)
    and it finally works.

    I hope it stays like that (I didn’t install QFE yet).
    Be careful installing Net F 4.0 as often it cannot be uninstalled (as on my computer). Remember to use System restore points, it’s the only way when Net F 4.0 becomes corrupted.

  3. Simpler than that:
    Just uninstall NET Framework 4.0 Client Profile and
    NET Framework 4 Extended and install LocStudio. It works everytime, as I did it in several computers.

  4. @MR: Thanks, for the input. Yes, that will also work. But as I need .NET Framework 4 Extended for other purposes I have to install the Standalone installer.

  5. Johnny – I cannot uninstall the Client Profile alone – I am informed that I have to remove Extended, which is the standalone version first.
    I, like you, need the .NET Framework for other stuff…
    So any suggestions????

    • Hi Frank,

      Unfortunately my site was hit by malware, but it should be cleaned up by now.

      The main problem is the installation of LocStudio 4.8. After you have installed LocStudio 4.8 you can install .NET FrameWork 4 again.

  6. Hi everbody
    Hope you are doing fine
    We need your help about LocStudio 4.8, when we try to run LocVer, I receive the below error in the tool:

    TPLocVer204 : Starting verification –
    Error : LSU1006 : The item could not be processed – The data contained in the LocCultures.xml file is invalid : An error occurred loading element ‘LocCulture’ at line 3 position 184 – Culture with LCID 1 already exists\r\nParameter name: LCID
    TPLocVer201 : Finished verification – 1:18:49 PM 11/15/2012

    Any of your guys have experience with this issue?
    Ss
    Looking forward to your answers,
    Thanks in advance.
    Best regards.
    Fede

Leave a Reply

Please leave this field empty.

Contact Us:

* Name * Email
* Message



word gallery I/S
Grønnevej 10
DK-4600 Køge
Denmark


Mobile: +45 31 61 46 64


VAT Number: DK26161835


Vis stort kort